Cannot select Arcbotic's board


#1

I slavishly followed the set-up instructions and can get the first example program (“do nothing”) to run through the check program cycle OK. However, when I try to upload it, I am told that the board is “Arduino / Genuine Uno” and get the error shown below: When I go to Tools=>Boards, there is no "Arcbotic Sparki.’ board to select. All of the examples get installed, so I know I am doing something right. How do I get the “Arcbotic Sparki” board to show up un the list?

I would appreciate it if someone could set me straight. (My friend has abolutely no problems running it on his Mac).

Arduino: 1.6.9 (Windows 7), Board: “Arduino/Genuino Uno”

C:\Program Files (x86)\SparkiDuino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files Sketch uses 444 bytes (1%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x33
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x33

Problem uploading to board. See arduino.cc/en/Guide/Troubleshooting#upload for suggestions.


#2

[quote=“roboaldchemist”]First, if Sparki isn’t showing, that’s a problem. Try follow this zcode guide to get it back:
arcbotics.com/support/sparki-doe … arkiduino/

Second, if you can’t get the Sparki board to show up, you can select Arduino Leonardo, the Arduino that Sparki is based off of. The problem here is that Arduino Uno was selected.[/quote]

I’m seeing similar stuff, did you find out what the issue was and how to fix?


#3

First, if Sparki isn’t showing, that’s a problem. Try following this guide to get it back:
arcbotics.com/support/sparki-doe … arkiduino/

Second, if you can’t get the Sparki board to show up, you can select Arduino Leonardo, the Arduino that Sparki is based off of. The problem here is that Arduino Uno was selected.