miniBloq drag-and-drop Test Release


#1

We’re excited to have a test build up for miniBloq!

We know a lot of other people are also really excited to get started, play with miniBloq, and get lessons made, so we’re posting a test release below.

We still have a few days of documentation and testing left before we’re comfortable releasing it on the start page as 100% working, so play with it knowing that:

miniBloq 0.82.1 TEST RELEASE windows installer

Update: New version

miniBloq 0.82.2 TEST RELEASE windows installer

Let us know any feedback you have, or suggestions.


Sparki for 9 years boy
easy middle school curriculum
#2

OSX Beta, too?


#3

Sorry, miniBloq isn’t available for OSX. There’s not much we can do about that, that’s miniBloq’s territory.


#4

You could try this for OS X. blog.minibloq.org/p/minibloq-mac-os-x.html


#5

Hmm, that is a disappointment. I wasn’t aware of that. But I see that there is a Linux version so I can run it in a VM. And usually if there is a Linux version there will be an OSX version, too. UNIX power! :slight_smile:

Edit: are there some instructions on how to set up vanilla minibloq with Sparki?


#6

It turned out to be kind of complicated (a couple dozen things), and definitely not something worth posting until everything is squared away.


#7

I went down the wine/wine bottle route that I linked above. Got to create an OS X app & everything. Minibloq runs through OS X for me. But, there are errors in compilation after I’ve put the blocks in place. Seems to be Sparki minibloq issue rather than wine bottle.

Anybody get to run the minibloq successfully on Windows?


#8

What errors are you getting?


#9

This is the error I get when I attempt to run the sample program:

C:\Program Files (x86)\miniBloq\work_examples\Sparki\10.avoidObstacles/avoidObstacles/avoidObstacles.cpp: In function ‘void setup()’:
C:\Program Files (x86)\miniBloq\work_examples\Sparki\10.avoidObstacles/avoidObstacles/avoidObstacles.cpp:9: error: ‘robot’ was not declared in this scope


#10

I experienced the same error as marajade.

I have some observations:
[ul]
[]website example code references sparki object whereas miniBloq references robot object[/]
[]miniBloq example code has logic in setup function, whereas website example code has this in loop function[/]
[]miniBloq and SparkiDuino both install drivers without a choice. I’m not sure how often the drivers change, but I can foresee a time where drivers are out of sync. Can the driver be made a separate install?[/]
[/ul]


#11

Yeah, the example miniBloq made for us became out of date as they used old code. The included examples in the release will all be compatible.

@Mathew: Good call. We’ll leave the driver update as an option in future installs, and publish a separate driver installer on the front page with the next round of updates.


#12

This looks great!
So, not using the out of date examples, but just the blocks to create my own program - when I try to run, I get errors.

[i]C:\Program Files (x86)\miniBloq\work_temp/comp1/output/SparkiWire.cpp.o: In function TwoWire::write(unsigned char const*, unsigned int)': C:\Program Files (x86)\miniBloq/libs/Arduino/Sparki/v1.0/SparkiWire.cpp:195: undefined reference totwi_transmit’
C:\Program Files (x86)\miniBloq\work_temp/comp1/output/SparkiWire.cpp.o: In function TwoWire::write(unsigned char)': C:\Program Files (x86)\miniBloq/libs/Arduino/Sparki/v1.0/SparkiWire.cpp:177: undefined reference totwi_transmit’
C:\Program Files (x86)\miniBloq\work_temp/comp1/output/SparkiWire.cpp.o: In function TwoWire::endTransmission(unsigned char)': C:\Program Files (x86)\miniBloq/libs/Arduino/Sparki/v1.0/SparkiWire.cpp:140: undefined reference totwi_writeTo’
C:\Program Files (x86)\miniBloq\work_temp/comp1/output/SparkiWire.cpp.o: In function TwoWire::requestFrom(unsigned char, unsigned char, unsigned char)': C:\Program Files (x86)\miniBloq/libs/Arduino/Sparki/v1.0/SparkiWire.cpp:85: undefined reference totwi_readFrom’

There are errors.[/i]

But, when I take that code and put it into sparkiduino it works fine. So at the mo I can use it in a rather long winded fashion (although strangely I don’t seem able to directly copy and paste for some reason - have to paste into word first, then copy and paste a second time (odd I know). Should I be worrying/letting you know that it won’t compile and run directly, or just wait for the next release?

Thanks!
(It is still helping me teach myself and my daughters a bit of programming, so I still see this a success!)


#13

I have the same errors as brucew_o and I also tried copying and pasting the code generated by miniBloq into Sparkiduino.

Surprisingly it works :slight_smile: , and I was wondering if this issue would be fixed by the next update, so that we can run Sparki just from the miniBloq?


#14

Just tried the new beta release. It seems that the additions were updating the Arduino Library, which fixes the TwoWire compiler errors noted by brucew_o, adding a couple examples, and updating the driver files. Is there a change log for the build in case there were other fixes?

The fix for the TwoWire issues is a little weird to me. It seems that the contents of [i]twi.h[/i] and [i]twi.c[/i] were copied into [i]SparkiWire.h[/i] and [i]SparkiWire.cpp[/i], respectively. I fixed the compiler errors in the previous beta by adding [i]twi.c[/i] to the Sparki build steps since the file was already included in the Sparki Library files (/libs/Arduino/Sparki/v1.0).

The build steps are found in [i]<Minibloq install dir>/hard/Sparki.v1.0/rel/action.020.0080.SparkiRobot.Arduino.v1.0.rel[/i]. The following [i]<cmd>[/i] block can be added inside the [i]<build>[/i] block.

<cmd>
    <s>"</s><s>toolsPath::</s>
    <s>/avr-gcc" -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -MMD</s>
    <s> -mmcu=</s><s>cpu::</s>
    <s> -DF_CPU=</s><s>clockFreq::</s>
    <s> -DARDUINO=</s><s>arduinoVersion::</s>
    <s> -I"</s> <s>toolsPath::</s>
    <s>" -I"</s><s>corePath::</s>
    <s>" -I"</s><s>corePath::</s><s>/avr-libc</s>
    <s>" -I"</s><s>corePath::</s><s>/variants/</s><s>arduinoVariant::</s>
    <s>" -I"</s><s>componentPath::</s>
    <s>" -I"</s><s>outputPath::</s><s>" </s>
    <s>-I"</s><s>libsPath::</s><s>/Arduino/Sparki/v1.0" </s>

    <s>"</s><s>libsPath::</s><s>/Arduino/Sparki/v1.0/twi.c" -o "</s><s>outputPath::</s><s>/twi.c.o"</s>
</cmd>

#15

Any chance of getting Scratch or it’s robotic modification Enchanting http://enchanting.robotclub.ab.ca/tiki-index.php running on Sparki? We use it for Mindstorms and I know Arduino can run scratch so it seems like there should be a way to get that working?
THanks.


#16

Its not technically unfeasible, but we don’t currently have plans at this time to do so.


#17

I’m sure I’m being an idiot, but I can’t actually work out how to actually upload the code from miniBloq into Sparki.

The best I’ve managed so far is to cut and paste the code into the arduino IDE.

That can’t be right can it?

Thanks for your help. Well done with Sparki btw. It’s great!


#18

Ok. I WAS an idiot.

I’ve got it now.

Under ‘component’ hit ‘run’.

I found a really useful introductory guide here: blog.minibloq.org/2014/07/new-be … t-and.html.

It’s for a Pi bot (confusingly nothing to do with a Raspberry Pi). But it’s useful anyway.

Perhaps Arcbotics could include a link to this site somewhere (you probably do already somewhere but I missed it).