Seeming Hardware Issue with our Sparki


#1

Hi,

Lately, whenever we have tried to use our Sparki, once it is on battery power, it seems to crash, and not run its program.

It looks like it might be a problem with the LCD, or at least the LCD shows the same type of output each time.

All I know is that when we turn on the switch, and the process of loading and running the program begins, at some point the LCD (after and while showing it’s startup graphic) gets a garbage line horizontally across it near the bottom, and nothing else happens.

This does not happen when connected to USB. It’s possible that it started happening when the batteries were lower, but now it does it almost every time even on new batteries.

If anyone has suggestions or ideas about how to solve this please let me know. I have a lot of software development experience, but I haven’t put any time into trying to debug the libraries or the startup process to get more information yet.

I am willing to replace parts if we can figure out what’s needed, and they are available.

Thanks!


#2

If its working on USB and not the batteries, the next step would be to try new batteries. Any luck with that?


#3

Yes, I replaced the batteries from a newly purchased pack. I can’t remember for certain (we haven’t been using it since it started misbehaving a lot), but I don’t believe it worked at all after the replacement. I will do some new testing today and try to give better information.

Is this a behavior that others have seen when their batteries get low?