Servotor32 2.0 Firmware


#21

Hi, I am running Servotor 2.0 und PoCoMo. When I send the “kill all servo” command some servos stay powered.

Another problem is that some of the servos do not move the whole angle range.

Any suggestions? Thank you!


#22

That’s a strange one, NH. A few things I would verify;

  • Are any of the servos connected to the board the wrong way around? The ground wire (brown, usually) should be connected to the pin closest to the edge of the board in all cases.
  • Are the servos all connected to the correct positions on the servotor board, according to the instructions?
  • When you swap the servos around, does the problem follow the servo, or does it stay at the servotor32 port?
  • Are the servos adequately powered?
  • Is the board adequately powered?

#23

Thank you fornthe quick respond. I think the servos are connected well. I can control each one at a time with PoCoMo. This way I found out that some do not move the whole angle. I used 4 NiMh rechargebale batteries, fully loaded. They seem to have enough power, as one servo already broke :cry: . I powered the servo plug only and connected the usb connection. In my opinion I might be a software problem or a servo failure?


#24

If they are all reacting to PoMoCo, when building it did you follow the directions on how to centre the servo horns?
Then, did you follow the directions for entering the offsets in PoMoCo?
Are the articulated joints hanging up on anything? Servo wires too tight?
Finally, have you upgraded the Servotor32 software to version 2.0?

If all this is true, and you still have limited motion on the servos, I’d test them connected by themselves one at a time to the Servotor32 board. Try them on channels 0, 1 and 2. Then you can determine if the servo is faulty. If the servos work correctly one by one, I bet it’s the power supply.


#25

Stupid me! I had a version of PoCoMo installed which works with Hexenstein (great stuff by the way). It works at the old baud rate. I now started to new version 1.0 of PoCoMo - everything fine! Thank you all for the quick support. Btw I powered hexy now with 5 NiMh. Now that hexy works at basic functionality I am keen to try a lot of things… I keep you updated from time to time!


#26

Dear Joe, do you have an update on this? I’d be very interested in this!

Another idea for future firmwares: Setting the offset inside the arduino. One could store the positions in EEPROM…


#27

In file included from /usr/share/arduino/libraries/Servotor32/Servotor32.cpp:1:0: /usr/share/arduino/libraries/Servotor32/Servotor32.h:4:28: fatal error: Servotor32_SPI.h: No such file or directory compilation terminated.

I have yet to find a solution to this. The first compiling problem was SERVOTOR vs Servotor in one of the libraries.

I put copies of the libraries into the arduino library folder and they show up in the “import” option, but it seems to make no difference.

Arduino 1.0.1 Linux.


#28

Binary sketch size: 10,920 bytes (of a 28,672 byte maximum) Found programmer: Id = "B§m"; type =

Those are the windows issues. 1.0.4 arduino IDE.

In case you saw it earlier, my errors were related to the fact that I didn’t have it set to a Leonardo, so it was confused.

It now compiles with no errors, but then it won’t upload.


#29

For what I want to do, I agree with ToomanySecrets. I am working with Servotor for now, but a mega would allow me to move autonomously easier than with the current board. I find it a little too black box. I am working with it directly in C and have it working. It roams and avoids barriers with the sonar. It is not ready for prime time yet, but is getting there. For instance, every so often, the sonar returns 0 for several seconds. Any reason for that?
DocBill


#30

[quote=“cecilden”]I have tried two different USB cables. Each one works with the Arduino Uno, neither powers the led light or HEXY. I tried the four battery pack in the 5V-10V input. Meter says I am supplying 6.5v with new batteries. The power LED does not light up.
I probed several spots on the board but could not read voltage (I can detect mV levels with the meter) but found no responses. OK, I thought, what if one of the 19 servors is somehow shorting out the boards ability to function. I unplugged all the servos (yuk) and plugged in the batter pack again. No power LED light. I checked the solder joints where the power is plugged in, the board is getting the voltage, the female socket is working. I checked the other socket (with no servo power pack plugged in) while the logic power was still plugged in. It showed -6.5 volts, so some voltage is getting to the board.
To be thorough I decided to check again with the USB cable. Wow, the green light came on and Arduino Leonardo showed up in the Device Manager under Other Devices. However I got an error related to the driver. Out of curiosity, I plugged in the infrared detector and lo and behold, the green light went out. So, I reverse it and the light stayed on. So, now I have hope of working out the problem. However, the logic batter back still will not light the power LED.
I have a project that will sap all my time for the next week or more, so won’t get back to this for a while.
I hope this information is useful to someone else as well.
Cecil
[/quote]
Can you pm me ? I think I can help you, but I’m not an expert… bt I’ll try my level best.


#31

I just thought I would check, where are the docs for the board software ? :confused:


#32

They’re pretty skimp at the moment, but we’re building them up soon:
github.com/ArcBotics/Hexy/wiki/Servotor32


#33

awesome, thanks


#34

I feel like a total noob here but… i am attempting to upload the new firmware, however every time i try to compile the firmware, i get an assortment of error messages,
Servotor32_Default/Servotor32.cpp.o: In function Servotor32': /Users/Zach/Documents/Arduino/libraries/Servotor32_Default/Servotor32.cpp:13: multiple definition ofServotor32::Servotor32()'
How do i fix this/ what am i doing wrong?


#35

Just wondering when will the new version of pomoco will be posted? It’s been 2 weeks now:(


#36

roboalchemist,

Any update, I’m wondering too when the new version will be posted.
Also you mentioned about developing a ‘Arduino move code generator’ back in December?

Cheers,
Chris.


#37

roboalchemist,

I agree with @cem, any news for the updated firmware version for hexy. I remembered you mentioned before and it’s been a month now. We are all excited before and now…well, we have a lots of projects in mind. Cheers

-relodan


#38

Many of us have been waiting to hear about when the firmware upgrades will be available.
I am surprised that I do not even find Beta versions on GitHub.

I to am really looking forward to seeing some of the promises realized.


#39

Thanks for informing


#40

Where can I find the servotor32 V2.1 Firmware?