Updated Arduino now Arcbotics Sparki board no longer on list

Was using the Sketch_mar14 edit software and it mentioned an update for the board was available so I installed it. I did not notice this update was not for the arcbotics sparki. Now, the board no longer shows up on the list of available boards (only Arduino Yun and others do). I uninstalled the software and reinstalled, no help. Went to Arcbotics and installed the drivers, no help. The board still does not show up on the list of available boards. Anyone figure out how to wipe the drivers and reinstall?

I encountered the same problem. I can’t find where it updated this and undo it. It seems to be on a local user account because it happened separately on two user accounts on my computer. I tried following suggestions from this 2 year old post here: Installation with standard Arduino IDE under OSX to update the board.txt file with the one from the new sparki installation, and that didn’t work. I tried working in the Arduino IDE as this suggests, and was able to load the libraries and update the boards.txt but it still didn’t recognize the Sparki board.

Well, I figured out this problem, but still having others.

This is on a Mac… I found the active boards.txt file in


and pasted in the ArcBotics sparki information that I found in the package contents of the SparkiDuino.app in the Applications folder, under

Now it at least attempts to talk to the Sparki, but I get compiler errors even on the Bare Minimum example.


This problem is caused when the Arduino program that SparkiDuino is built on updates to the latest version of Arduino - i.e. not SparkiDuino. It overwrites the boards.txt file. If you re-install from our site, that should fix it. We’ve turned off automatic updates in the latest version we’ve uploaded.

Have the same problem, but haven’t been able to cure it by uninstalling and reinstalling from the arcbotics site; sparkiduino still not showing up as a board option; it still shows yun as the top board. Might simply editing the boards.txt file solve the problem? (I’d try it but I’m afraid to dig myself a deeper hole, this issue arose as a result of my impulsive decision to proceed with a proposed update)
Snohomish, Washington

You should be able to solve this by uninstalling, deleting your arduino user files. They should be in:
C:\Users<Your User Name>\Documents\Arduino

Delete that folder after uninstalling, then re-install with a fresh version of SparkiDuino. The board should come back. (and automatic update prompts will now be disabled :wink:

also having this issue, and telling people to delete their sketchbook is not at all acceptable, and will not solve the issue anyway. maybe deleting the C:\Users<Your User Name>\AppData\Arduino15 folder would fix it, but then you lose everything in the normal arduino IDE too.

if you’re going to recompile the IDE, you really need to completely separate it, new sketchbook, new arduino15, everything. all my libraries and examples are mixed in with no way to separate what are Sparki examples and what aren’t and it’s a serious problem.

or, stop making your own IDE and just make a new board manager plugin like Arduino recommends and everyone else is doing. it’s the Right Way.

Yes, it appears they changed it with the 1.5 update.

We have’t dug deep enough into the arduino code to alter the sketchbook location.

To be fair, most people who use Sparki have never touched an Arduino before. We didn’t want to burden these people with getting the original installer installed, adding a library, running a separate driver installer, and adding a board file before even getting started. We especially didn’t want to burdern a teacher who has to get Sparki started on 20 laptops with doing this 20 different times.

That said, we do offer a seperate Sparki library if you are already running Arduino and just want to add Sparki to it:

You can run it as an Arduino Leonardo. You’re right in that we should be offering a board plugin (which is a relatively new thing), now that they offer the ability to. It’ll show up that downloads section when we have it.

I tried this on another PC to see if I could reproduce and correct it, and it could not. the process was as follows:

install arduino ide 1.6.8

install sparki ide

allow arduino ide to do a boards update

sparki is now gone in spariduino

remove both ides, sketchbook, and arduino15 folder, plug in sparki and delete driver in device manager

reinstall only the sparki ide, still no sparki in the boards list, but serial port does show up with no brand name on it.

Btw, we did end up making the board plugin like you suggested.

If you open up SparkiDuino and go to File > Preferences:
In the Additional Boards Manager Urls box, put in this:
raw.githubusercontent.com/ArcBo … index.json

Once you’ve done that, go to Tools > Boards > Board Manager.
With this open, select “ArcBotics Boards” (it might be at the bottom) and hit the install button that pops up in the lower-right. Your boards will re-appear.

sweet! I’ll test it tonight. I’ve also been having intermittent programming issues on some PCs, but not on others, where the IDE will say “uploading” and that’s it, no error, no timeout, and the sparki never enters programming mode. hopefully having the sparki board package corrects that too